Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 13, 2025 - 10:45 EDT
Scheduled
Our engineering team will be performing routine application upgrades and maintenance as part of our ongoing commitment to delivering a seamless, secure experience. This work will enhance reliability, performance, and security. We do not anticipate any service disruption, but if you experience issues during or after this window, please contact our Support team.
Posted Aug 08, 2025 - 16:18 EDT
This scheduled maintenance affected: Admins (Script Builder, Oncall Calendar, IVR, Reporting), Agents (Inbound Calls, Outbound Calls, Call Transfers, Call Conferences, Scripts, Recalls, To Dos, Live Chat), Users (Messages, Liberty Mobile App), Supervisors (Supervisor Dashboard, Supervisor Actions), APIs (Messages API, Call Recordings API, To Dos API), and SMS/MMS.